mercoledì 16 maggio 2007

Webcam Nortek ElementONE su Feisty




Finalmente ho trovato un momento per fare un po' di test con la webcam in oggetto.

Ecco cosa ha detto Ubuntu dopo l'inserimento del cavo USB:

[ 1903.512000] usb 3-1: new full speed USB device using uhci_hcd and address 2
[ 1903.672000] usb 3-1: configuration #1 chosen from 1 choice
[ 1903.868000] Linux video capture interface: v2.00
[ 1903.928000] /usr/src/modules/gspca/gspca_core.c: USB SPCA5XX camera found. SONIX sn9c10[1 2]
[ 1903.932000] /usr/src/modules/gspca/gspca_core.c: [spca5xx_probe:3983] Camera type SN9C
[ 1903.944000] /usr/src/modules/gspca/gspca_core.c: [spca5xx_getcapability:1189] maxw 640 maxh 480 minw 160 minh 120
[ 1903.944000] usbcore: registered new interface driver gspca
[ 1903.948000] /usr/src/modules/gspca/gspca_core.c: gspca driver 01.00.12 registered
[ 1904.028000] sn9c102: V4L2 driver for SN9C10x PC Camera Controllers v1:1.27
[ 1904.028000] usbcore: registered new interface driver sn9c102

Poi ho lanciato il comando camorama ed e' apparsa questa oscenità [1]:


Per togliere quel poco naturale colore blu occorre cliccare con il tasto destro sul riquadro "Effects" e selezionare Add effect -> Color Correction.

AGGIORNAMENTO: per risolvere il problema del colore blu potete seguire i seguenti passi:

sudo gedit /etc/modprobe.d/options

inserire la riga:
options gspca force_rgb=1

sudo modprobe -r gspca
sudo modprobe gspca



Ecco il risultato:


I cursori delle regolazioni sembrano non sortire alcun effetto a parte quello del contrasto.


[1]: intendevo il colore blu, non le mie fattezze....

1 commento:

Tipolosko ha detto...

Grazie! Finalmente, grazie a te, sono riuscito a far funzionare la mia webcam! MI-TI-CO :)